Ubuntu (Precise, 12.04) won’t shutdown or reboot normally–workaround

Shutdown (or reboot) freezes on the purple screen with the Ubuntu logo, sometimes I get the dots, sometimes I don’t. At that point even holding in the power button on the front of the case does not shut the system down. I have to use the power rocker on the system power supply to shut it down completely. There is a bug report on this, but so far no fix.

Usable workarounds:

  • Suspend works.
  • If I log out and then shutdown from the login screen the system shuts down fine.

My development system, on the other hand shuts down and reboots as it should. Most of the early problem reports were on systems with Nvidia video cards, but my HTPC (with the problem) uses an ATI card, while my development system (without the problem) uses a Nvidia card.

In any event, I won’t be moving any of my other systems to 12.04 until the problem is resolved.

Advertisements

Posted on May 21, 2012, in 12.04 and tagged , , . Bookmark the permalink. 2 Comments.

  1. Paul Stimpson

    Hi,

    This sounds like an issue I have an open bug on. Please feel free to sign up or “affects me too”. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/992488

    Thanks,
    Paul.

  2. After the latest update, the reboot worked as it should, perhaps teh problem is resolved

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: